Warning: Creating default object from empty value in /homepages/11/d132647312/htdocs/Amfone/mkportal/include/SMF/smf_out.php on line 47
Rods Class D/E transmitter




 
The AM Forum
August 09, 2020, 01:45:31 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
 
   Home   Help Calendar Links Staff List Gallery Login Register  
Pages: [1]   Go Down
  Print  
Author Topic: Rods Class D/E transmitter  (Read 894 times)
0 Members and 1 Guest are viewing this topic.
vk3alk
Member

Offline Offline

Posts: 118


« on: February 23, 2020, 11:02:53 PM »

Have just built up Rod's Transmitter.....

Goes well .... very well .....
Built as is the load is 3R... just a little too low for me so reduced the secondary turns from 11 down to 7 on each transformer and the load went up to 6.6R...
My Bench Supply is suited more for high voltage and low current so could not push the module more then 185 watt DC input...
The output power was in the low 170 watt level so the efficiency is in the 90% plus range...
Left the TX going for about 30 minutes into my Dummy Load and everything ran cool .... everything cool... Smiley

I am certain the module could be pushed to much higher power levels but will leave that to others etc:

Probably best not to exceed a load of 6.6R or so ... just to keep the Class E waveforms under control....

Of all the push pull transmitters that have built overtime would say this has been the best....


Wayne



* Rods Class DE 75M.JPG (468.91 KB, 1600x1200 - viewed 229 times.)
Logged
K8DI
Contributing
Member
*
Offline Offline

Posts: 148


« Reply #1 on: February 25, 2020, 10:11:17 AM »

Hi Wayne --

Can you post a link or copy of the schematic for this variation?  I've been looking at tons of D/E circuits and transmitters lately, but this looks simple and buildable compared to many others, it uses far fewer inductors, and standard capacitors, and will therefore be much cheaper, too.

Also, I understand your power supply was a limitation, but what kind of voltage were you running to get the 17o watt output?

Ed
Logged

Ed, K8DI, warming the air with RF, and working on lighting the shack with thoriated tungsten and mercury vapor...
N4LTA
Contributing
Member
*
Offline Offline

Posts: 989


« Reply #2 on: February 25, 2020, 11:40:53 AM »

Looks great Wayne. I hope to have my transmitter working soon.

I had some trouble with my PWM power circuit. The IR driver IC and the 2N7000 inverter don't seem happy. The inverted signal looks great until it is fed into the driver input and then it is badly distorted. Maybe the chip input is damaged. I'll work on it some more.

My circuit is pretty much the same as Rod's except I have two FETS in Parallel on each side and a single transformer. It seems to be working fine but I need my PWM power supply working to test further. I have it all in a Hammond rack enclosure with meters and have tested the power supply and regulator to 147 volts at 5.6 amps. I just need to get the switcher working properly and get it all boxed up.

Pat
N4LTA
Logged
vk3alk
Member

Offline Offline

Posts: 118


« Reply #3 on: February 25, 2020, 04:43:43 PM »

Hi Ed....

Rod uploaded the circuit in a post not too long ago but here it is....

For 185 Watts input the voltage level was around mid 30s say 35 volts.....
35 volts divided by 6.6R = 5amps times the voltage = 185 watts or so etc:

The cores I used were originally T106-2 but wound them out of phase ( we all make mistakes I suppose ).....so had some T157-2 cores and used them...

Remember its not my circuit ..... it came from Rod ....so he probably has some stories to tell..


Wayne

Pat ... will have another read of your post....just got to get ready for work...


* ClassD_E PA.jpg (114.33 KB, 1000x755 - viewed 294 times.)
Logged
vk3alk
Member

Offline Offline

Posts: 118


« Reply #4 on: February 25, 2020, 06:23:10 PM »

Hi Pat....

You would not think the inputs pins 10 and 12 could be damaged .... the outputs maybe due to a short to ground perhaps. Shocked

Your pull up resistors values 2N7000.... I use 1Kohm .... perhaps yours are too high etc:



Wayne
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

AMfone - Dedicated to Amplitude Modulation on the Amateur Radio Bands
 AMfone 2001-2015
Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
Page created in 0.073 seconds with 18 queries.